◆ 完全に IE のサポートはしないみたい
◆ 良い流れ

Bootstrap が IE サポートをやめるみたいなことを聞いたので見てみました

こんな PR があってマージされていますね
v5: drop Internet Explorer support #30377

.browserslistrc には 「not Explorer <= 11」 と書かれています
IE 全部が not なので IE は対象外ということのようです

issues で IE 関係のものを探してみると IE サポートするしないで議論があったりしますが 2019 年のもので 16 日前の 2020 年 3 月にこれがマージされてるあたりサポートしないのが確定したのでしょうね

個人的には bootstrap は使ってないのでどっちでもいいところではありますが 有名ライブラリが IE サポートを切るのは大きいことだと思います
この調子で IE サポートするライブラリやサイトが減っていくといいですね